Disk Copy

Spread the love

1: What is SubRosaSoft Disk Copy?

SubRosaSoft Disk Copy is a well-rounded and very easy-to-use backup and cloning system. It can create bootable copies of startup drive, manage synchronization of volumes, handle incremental bootable copies, and support scheduling for automated processes.

SubRosaSoft Disk Copy supports multiple backup modes:

  • Clone — creates a bootable clone of your Mac volume.
  • Synchronization — only new and updated files are copied from your source to your destination during a backup.
  • Incremental Snapshots — backs up your most recent changes, and retains older versions of files that you can retrieve, if needed.
  • Scheduled Backups — perform automated backups at times convenient for you.

Written specifically for Mac OS X Yosemite and above, SubRosaSoft Disk Copy includes powerful features that give you greater control and flexibility over cloning, backup, and the duplication of data:

  • Easy-to-use interface — The application’s single-window design makes cloning and backing up a simple process.
  • Extremely fast incremental backups — Instead of cloning an entire drive, this feature adds only new or updated files to your destination.
  • Filtering capability — Allows you to exclude files from a backup.
  • Stop and Resume — Interrupt a backup and start it again later.
  • Save your backup settings — Use Disk Copy’s scheduling features to create automatic backups or to save settings for manual backups you can run when needed.

2: Getting Started — The Basics of SubRosaSoft Disk Copy

System Requirements

SubRosaSoft Disk Copy is designed to run on Macs with the following minimum specifications:

  • Apple Power Macintosh CPU (64-bit Intel based)
  • Mac OS X (10.10 Yosemite or higher)
  • At least 2 GB of RAM

Registration Number

Each user is required to have a registration number to complete installation of the software.

Online Purchase

When purchasing the software online at: https://www.subrosasoft.com/, the registration number is automatically emailed as part of the purchase confirmation. If a confirmation email does not appear in your email inbox, please check that it is not in the junk mail folder before requesting technical support. Please print your confirmation email, and store it in a safe and secure place for future reference.

No Registration Number — Trial mode

Even without a registration number, SubRosaSoft Disk Copy is fully functional for up to 30 days. After that, the software will require a registration number to continue to work. Purchase the software online from www.subrosasoft.com or via a retail channel, then simply select “Enter License Key” from the SubRosaSoft Disk Copy drop menu, and enter your registration number. An alternative way to register the product is to click the serial number link provided in your confirmation email.

Lost Registration Numbers

Please ensure that you keep your registration number in a safe and secure place. Print out confirmation emails, or back them up. SubRosaSoft cannot guarantee the re-issue of serial numbers for our software.

Site Licenses

Site Licences can be purchased online via https://www.subrosasoft.com/. For volume discounts please contact us directly via email: sales@subrosasoft.com.

Obtaining the Latest Version

Downloading from the Web Site

It is important to have the latest version of the SubRosaSoft Disk Copy software. The latest version is always available for download on our web site at: https://www.subrosasoft.com/

SubRosaSoft site

A download link, alongside version information, appears on the product page of the site. Simply click the link; a compressed archive file will automatically begin to download to the desktop, or another location you choose.

SubRosaSoft Disk Copy versions are distributed in DMG format, and can be mounted on the Desktop in the Mac OS Finder by simply double-clicking the file icon. In the Disk Copy window, you will find the SubRosaSoft Disk Copy application, the latest Read Me document, and a quick start guide.

Installing or Updating via Download

Once the software has been downloaded from the site and decompressed, simply drag SubRosaSoft Disk Copy from the disk image window into the Applications folder. If prompted to replace an existing version of the file, click Replace.

Removing the software

To remove the software, drag the SubRosaSoft Disk Copy from the Applications folder into the Trash can.

Finding Help & Technical Support

Should you need assistance while working with SubRosaSoft Disk Copy, there are a number of sources for help:

Help within SubRosaSoft Disk Copy

To get help with any questions you may have about the operation of SubRosaSoft Disk Copy, select ‘SRS Disk Copy Help’ from the drop-down Help menu.

Technical Support

Our technical support is free via email and can be accessed at the following address: support@subrosasoft.com. The support hours are 10am to 6pm Pacific Standard Time Monday through Friday (GMT -8).

In addition to any support question(s), you must include ALL of the following pieces of information:

  • Valid registration number.
  • System configuration(s) — hard drive make, model, memory configuration, and the model of the Mac you are running the software on.
  • System OS version.

3: Using SubRosaSoft Disk Copy

Initial Setup

When you first launch SubRosaSoft Disk Copy, you will be asked to input the registration number. If you don’t have a registration number, you can run the software in Trial mode for up to 30 days. After 30 days from the initial launch, the software will cease to work until you enter a registration number.

The first time you run Disk Copy, it will ask for your administrator password; authentication is necessary to perform operations on the startup drive. Once authenticated, Disk Copy will be ready for backup or cloning.

Quick Tip: Password for Authentication Process
Your administrator password is the primary password for your Mac, and not one assigned by us. If you don’t have a password, you will need to assign one to the system before using SubRosaSoft Disk Copy.

The Main Window – An Overview

Immediately after start-up, you will see the ‘Main Window’. This is the starting point for any task you wish to perform. For more on the using the Main Window, please scroll down to the section on Main Window.

Menu Items

There are a few items on the menu bar specific to SubRosaSoft Disk Copy:

Drive Cleaner Help Menu

Enter License Key…

Selecting Enter License Key… displays a window for entering the Registration number (if the software is running in Trial mode). The menu is disabled if a serial number has already been entered.

Check For Updates…

Selecting Check For Updates… tells SubRosaSoft Disk Copy to check with SubRosaSoft.com to see if a newer version is available.

Preferences…

Selecting Preferences… displays a window where you can tailor your backup experience.

Disk Copy File Menu

Restore Backup…

Selecting Restore Backup… allows you to select a folder or a volume to restore from. See Restore Backup… section for more information on Restoring Backups.

Disk Copy Help Menu

Help

Selecting Help opens SubRosaSoft Disk Copy’s html-based help file in your default web browser. You must be connected to the Internet to use our online help.

The Preferences… Window

Preference Window

Wait until power is connected before starting a scheduled backup. For laptop users, SubRosaSoft Disk Copy can wait until power is connected before running a scheduled backup. Disk Copy may not be able to complete the backup if the computer runs out of battery.

Never delete anything on the root level of the Destination (recommended). The root directory of a volume contains files necessary to make the volume bootable. This option prevents Disk Copy from overwriting those files in the rare event that an essential folder has been emptied of its contents. Unchecking this option may render the drive unbootable.

Show file copy animation. Display thumbnail icons of each file that’s being backup, showing current files in their generic icons moving from source to destination. If you are not a fan of animated icons, you can turn them off by clicking on the check box. Performance is not affected by this option.

Animation On
Figure x: File copy animation on
Animation Off
Figure X: File copy animation off
Quick Tip: Toggling copy animation
You can also toggle on or off file copy animation by clicking on the Blue Arrow during the backup process.

The Main Window’s Layout

Main Window Layout

Source

Select a volume, file or folder to copy from.

For bootable backups, select either a volume, or the folder created by a previous backup. Note you can also select a previously created Incremental Snapshot of a volume, and it will be restored as a bootable volume.

Destination

Select a destination a volume or folder to backup to.

Make Clone

You can perform Direct Cloning or Synchronization by backing up using Make Clone

Direct Cloning: Make an exact duplicate of a folder or disk. Unlike dragging and dropping files in the Finder, this feature copies linked, locked, and hidden files, as well as special files, such as System files, which the Mac doesn’t usually allow users to copy. It also preserves creation and modifications dates, which can be lost when performing simple copies in the Finder.

Synchronization: Updates a previous clone. If you have an existing clone, Disk Copy can analyze the clone and use Synchronization to update it. This process is much faster than creating a clone from scratch since it only copies the files that are different between the source and destination.

Notes: Disk Copy’s Synchronization is one-way—source to destination. When synchronizing, any new or altered items on the source will be copied to the destination. Any items that have been deleted from the source will be moved to the destination’s trash. By default, Disk Copy will not remove items from the root directory of your destination to prevent accidental deletion of files necessary for bootable volumes. You can change this in Preferences if you wish.

Make Incremental Snapshot

Incremental snapshots protect you in those seemingly inevitable situations where you have accidentally overwritten a file that contained important data or accidentally deleted a file you wanted to keep. Disk Copy’s snapshots save files whenever you have made a change to them, and they preserve files you have deleted. This allows you to go back and locate the version you need and copy it back to your source volume. You can even restore the whole volume, if needed.

An Incremental Snapshot appears to be a brand new copy of Source, but it’s actually only storing fresh copies of the files that have been changed since the previous backup, and the rest are hard links to the previous backup, which is extremely space efficient and fast to create.

The best way to use Incremental Snapshots is to set up a daily schedule to make Snapshots of your source drive. Each Snapshot is named with the date and time, making it easy for you to go back at any point and pull out preserved copies of any particular files you want.

Quick Tip: Deleting Snapshots
It’s okay to delete all of the incremental Snapshots in the Finder except for the last complete one that was made – SubRosaSoft Disk Copy uses it to make the next one. If you do delete the complete Snapshot, the next time Disk Copy runs a backup it will make a full clone again, and only afterward will it be able to make Snapshots based on the last backup it made. All of this behavior is automatic and transparent.
Note: Tech Notes on Hard Links
Disk Copy is able to save disk space in incremental backups using a something called “hard links.” You can think of these much like aliases (or shortcut icons) in the Finder, where each alias point to one original file. When Disk Copy is running an Incremental Snapshot and comes across a file that has not been changed since the previous backup, instead of copying the file again, it simply makes a hard link to the file already in the original backup. This way a complete backup of a volume may take about 1% of the space of the original, yet be fully functional.
Saved Backups & Schedules

Disk Copy allows you to set up backups you can run manually or automatically using scheduled options. You can set up many different backups to suit your needs.

For more details on setting up Scheduled Backups, please scroll down further.

Scheduled Backup Panel

Using Disk Copy

There are two options in Backup

Make clone

To begin any type of backup, you first select your Source and Destination. Click the icon on the left side of the main window to choose your Source (which can be a volume or a folder) for cloning, and then click the icon on the right to choose your Destination (a volume if you want to make a clone). Note that you can also use the drop down menus to make your selections.

Once you have selected the Source and Destination, make sure Make Clone is selected, and click on Backup to start the cloning process.

If the destination is an empty volume, Disk Copy will make an identical copy of the source on the destination. If the drive already has a previous version of the Source drive, Disk Copy will attempt to Synchronize the Source with the Destination.

Make Clone

Stop/Resume backups A clone or sync backup can be interrupted and started again at any time. You can click on the Stop button or quit the application completely, and resume by clicking Backup. In the backup window, the button label switches between Stop and Backup depending on where you are in the process.

Stopping a backup

If you haven’t changed the Source or Destination, the previous backup will resume from the point it stopped, rather than starting from scratch.

For example, in the screen shot above, 109 thousand of about 252 thousand files have been copied. The users suspends the backup by clicking the Stop, then resumes by clicking Backup. Before copying any more files, Disk Copy assesses what remains to be copied. In the image below, you can see that it resumed the backup with only the remaining 140 thousand files, instead of starting all over again.

NOTE: Reassessing can take a few minutes or longer depending on how many files are included in your backup. However, this process ensures that even files you have changed while the backup was stopped are properly backed up when you resume.

Resuming a backup

Make Incremental Snapshot

Incremental Snapshots copy only files that differ from your last clone. If you have changed a file, added files or folders, or deleted files or folders, just those files affected are changed. Disk Copy uses “hard links” to save space and still provide you with the most flexibility.

Incremental Snapshots are usually scheduled backups that run when you want. Open the Saved Backups & Schedules panel using the triangle icon, then choose the days of the week and the time of day for your backup.

Setting up Incremental Schedules Set

Note: You can have multiple scheduled backups but you can only have one for each source/destination combination.

Setting up Multiple Schedules Sets

The name of the Snapshot folder Disk Copy creates when making an incremental backup uses the international standard Day-Month-Year format, rather than the Month-Day-Year format common in the United States.

For example, the example below shows a folder with the name “SDC Snapshot 05-11-2015 Thu 17:00 PM”. The 05-11-2015 of the folder title represents November 5th, 2015.

Incremental Snapshot Naming Convention

When the next incremental snapshot occurs it will use this as the reference point to only create copies of the files that have been changed, and create hard links to the files that have not.

Quick Tip: Avoid renaming or removing snapshots
For incremental backup to occur the folder must not have been moved, and the backup must be saved in the list of Saved Backups. Backups are automatically saved to the list when they are of the type incremental Snapshot when you hit Backup
Saved Backups & Schedules

To configure the settings for Saved Backups & Schedules, click on the tab triangle.

After you have set a scheduled backup, backing up becomes a matter of simply plugging in your backup drive.

Setting up Scheduled Backup 1

You can select the day of week you want the automated process to run. Toggle the day on or off by clicking on the day; days highlighted in blue are days you want your backup to occur. You can also set a time when the process gets started, and the number of Snapshots folder to keep before the deleting the oldest snapshot folder.

For example, on the setup shown below, the backup is scheduled to begin at 8:00 PM every day.

Setting up Scheduled Backup 2

Once you click on Save, the source, destination, days, and time, and the type of backup will be listed in the panel below.

At the scheduled days and times, Disk Copy will automatically start your backups.

Setting up Scheduled Backup 3

You can use the Saved Backups & Schedules feature to save manual backup settings, as well. Simply set up the backup as you would normally, then toggle off every day of the week.

When you want to run a backup manually, launch Disk Copy, double-click the backup you want, then click the Backup button.

For example, the third item in the following screenshot is set up without days and time.

Setting up Manual Launch

Double-clicking this item tells Disk Copy to make a new Incremental Snapshot for “USB Work” in the “USB Work Inc Snapshot” folder. Then simply click Backup.

Double Click to Launch

Notes: Automatic backups

If the Destination is not available at the scheduled backup time, SubRosaSoft Disk Copy will wait until the destination drive is connected and automatically launch to start the backup.

Excluding files from Cloning

To exclude files from being copy, you can select Exclude from the main window.

Setting up Exclude Filter

Click on the + button. A window for folder and files selection will appear. Navigate to the file or folder you want to exclude from being copied and click on Open.

Select Files to Filter

Disk Copy will return you to the previous window. Select more files to exclude, or click Done to complete the process.

Exclude Filter Configured

How to restore

Locate the backup that you want to restore. It can be any of the above (a Clone, a Synchronized Clone, or a Snapshot). Select it, and then switch the source and destinations, with the backup as the Source. If you selected a copy of your bootable backup, then by restoring it (even from a Snapshot), you will re-create a bootable startup disk.

Restore using the Restore Backup… menu

You can also perform the restore using the Restore Backup… menu.

Disk Copy File Menu

Selecting Restore Backup… will allow you to select a folder or a volume to restore from.

Open Source for Restoring from

Navigate to the Volume or the folder you want to restore from, and then click on the Select Restore Source button. A window will open up and allow you to choose Restore to destination. Click on Select Restore Destination to initiate the restore process.

Open Destination for Restoring to

Warning: Disk Copy restore files without checking for newer changes.
If you want more granular control, you can use the folders and files in your Clones or Snapshots to manually restore them in the Finder.

Appendices

C – Copyright, EULA and Trademarks

Copyright Notice

SubRosaSoft.com Inc copyrights this software, the product design, and design concepts with all rights reserved. Your rights with regard to the software and manual are subject to the restrictions and limitations imposed by the copyright laws of the United States of America.

Under the copyright laws, neither the programs nor the manual may be copied, reproduced, translated, transmitted or reduced to any printed or electronic medium or to any machine-readable form, in whole or in part, without the written consent of SubRosaSoft.com Inc.

© Copyright 2016 SubRosaSoft.com Inc. All Rights Reserved.

End User License Agreement for SubRosaSoft Disk Copy – Click Here
Trademarks

“SubRosaSoft Disk Copy” is a trademark of SubRosaSoft.com Inc.

All other brand and product names are trademarks or registered trademarks of their respective holders.